We have completed the update. If you experience any issues with reporting, let us know by emailing support@ihealthhome.com.
Posted Mar 03, 2025 - 20:13 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2025 - 20:00 PST
Scheduled
We will be upgrading our reporting system during this maintenance window. If you are using reports during this time, you might get logged out. If you experience any kind of errors during this window, go back to the main home page for CNS, and then back to the Admin->Reporting section.
Posted Feb 28, 2025 - 15:04 PST
This scheduled maintenance affected: Care Navigation System (CNS) and Reporting.